우분투 서버 18-04.3 버전에 docker-compose를 설치해 봅니다.

 

 

 

1. docker-compose 설치하기

 

GitHub의 Compose 저장소 릴리스 페이지에서 Docker Compose 바이너리를 다운로드할 수 있습니다.

터미널에서 curl 다음 명령을 실행하여 바이너리를 다운로드해봅시다.

 

$sudo curl -L "https://github.com/docker/compose/releases/download/1.26.0/docker-compose-$(uname -s)-$(uname -m)" -o /usr/local/bin/docker-compose

 

 

** 만약 다른 버전을 사용하고 싶으시다면 "1.26.0"을 원하는 버전으로 변경해서 다운 받으시면 됩니다.

** 만약 알파인(alpine) 버전을 다운 받았다면 py-pip, python-dev, libffi-dev, openssl-dev, gcc, libc-dev, make의 추가 패키지가 필요할 수 있습니다.

 

 

20.02.14 추가 내용

 

정확한 원인은 알 수 없으나 1.25.0 버전을 위와같이 설치하면 계속 CURL 에러가 발생합니다. 만약 반드시 1.25.0 버전이 필요한 경우가 아니라면 다음 명령어를 통해 설치하는것을 추천드립니다.

 

$sudo curl -L https://github.com/docker/compose/releases/download/1.25.4/docker-compose-`uname -s`-`uname -m` -o /usr/local/bin/docker-compose 

 

 

 

2. 권한 부여

 

정상적으로 다운받았다면 다음 명령을 실행 해 바이너리에 권한을 부여합니다.

 

$sudo chmod +x /usr/local/bin/docker-compose

 

 

** 만약 명령이 실패한다면 docker-compose의 경로를 확인해 주세요.

 

 

 

3. 설치 확인

 

정상적으로 설치되었는지 다음 명령어로 확인해 봅니다.

 

$docker-compose --version

 

 

 

 

** 수정. 

2020.06.28 docker compose 버전을 1.2.5에서 1.2.6으로 변경.

 

 

+ Recent posts